User Tools

Site Tools


3rdparty:ioncube

Installation of the PHP Ioncube Loader on Debian-like distributions

The example is for PHP 5.6 as provided by Ondřej Surý repository. The procedure is identical for all PHP versions that are provided by the Ondřej Surý repository. You MUST just adapt the paths according the PHP version that you target.

Retrieve the path for the PHP extensions

USER
$ php5.6 -i | grep extension_dir extension_dir ⇒ /usr/lib/php/20131226 ⇒ /usr/lib/php/20131226

The path is:

/usr/lib/php/20131226

Download, extract and install the IonCube Loader for PHP 5.6

ROOT
# cd /usr/local/src/ # wget https://downloads.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gz # tar xfz ioncube_loaders_lin_x86-64.tar.gz # cd ioncube/ # cp ioncube_loader_lin_5.6.so /usr/lib/php/20131226/ioncube.so

Create the /etc/php/5.6/mods-available/ioncube.ini INI file for PHP 5.6 with the following content

; Configuration for the IonCube Loader
; priority=01
zend_extension=ioncube.so

Activate the IonCube Loader for PHP 5.6

ROOT
# phpenmod ioncube

Check that the IonCube Loader for PHP 5.6 has been correctly activated

USER
$ php5.6 -v PHP 5.6.36-1+0~20180505045733.13+jessie~1.gbp9b5cab (cli) Copyright © 1997-2016 The PHP Group Zend Engine v2.6.0, Copyright © 1998-2016 Zend Technologies

with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.1, Copyright (c) 2002-2018, by ionCube Ltd.
with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies

Restart the appropriate service

If you use PHP through PHP-FPM

ROOT
# service php5.6-fpm restart

If you use PHP through Apache2 FastCGI module (e.g. Fcgid)

ROOT
# service apache2 restart

/var/www/virtual/i-mscp.net/wiki/htdocs/data/pages/3rdparty/ioncube.txt · Last modified: 2018/05/21 19:30 by nuxwin